#88 ✓resolved
Jason Garber

RubyGems 1.3 barfs on camel-case RedCloth

Reported by Jason Garber | November 18th, 2008 @ 02:24 PM | in 4.1.1

Carried over from #80:


I had everything working fine on my development machine; Rails 2.1.0, gem 1.2, RedCloth 4.0.3. Then I pushed a deployment out to a VPS slice running Ubuntu 8.04 64 bit, with Rails 2.1, gem 1.3.0. I installed the latest RedCloth, 4.1.0 and everything fell to pieces.

My initial problem was the issue with the capitalization in the require statement. In my development machine it had to be RedCloth, which didn't work on the deployment machine. (I've tried updating my gem version but the update process falls over - that's a separate issue).

The earlier gem version 1.2 will choke on "require 'redcloth' " with the echoe error So it has to be "require 'RedCloth' ", the new gem version will fall over with "require 'RedCloth' ", so it has to be "require 'redcloth'". Though version 4.0.3 of RedCloth will accept "require 'RedCloth'" using both gem versions 1.3 and 1.2.

Gem version 1.2 doesn't recognize that echoe is a development gem which is why you must use "require 'RedCloth'". Gem version 1.3 does recognise echoe as a development gem, but barfs on the camel cased require, which is why you must use "require 'redcloth'".

So if you're like me, stuck with a gem version 1.2 on a development machine, but loading up gem version 1.3 on a production machine, you can only use RedCloth 4.0.3.

To try out these different variants you could use Amazon EC2. That's a cheap and easy way to set up new installations, try things out and throw them away when you're finished. If you've not used it before, email me and I'll send you some links to get you started.


John Small

Comments and changes to this ticket

  • Jason Garber

    Jason Garber November 19th, 2008 @ 09:43 AM

    • Title changed from “Capitalization problems on different RubyGem versions” to “RubyGems 1.3 barfs on camel-case RedCloth”
    • State changed from “new” to “open”
    • Tag set to gem
    • Milestone set to 4.1.1

    RubyGems 1.2

    The echoe problem is fixed in trunk already, so with the next RedCloth release you should be able to use require 'redcloth' with RubyGems 1.2.0.

    RubyGems 1.3

    You're right; require 'RedCloth' doesn't work with 4.1.0. I'm working on a fix.

  • Jason Garber

    Jason Garber November 19th, 2008 @ 10:52 AM

    • State changed from “open” to “resolved”

    (from [776ce2caa889255be341ee5c9b1cf333648945a3]) Added 'lib/case_sensitive_require' back into gemspec. [#88 state:resolved] http://github.com/jgarber/redclo...

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

RedCloth is a Ruby library for converting Textile into HTML

Shared Ticket Bins

People watching this ticket


Referenced by