#148 ✓resolved
Stephen Bannasch

problem building in jruby

Reported by Stephen Bannasch | May 16th, 2009 @ 09:09 PM | in 4.2.0

Using trunk jruby, redcloth, and ragel 6.3.0:

[redcloth.git (master)]$ jruby -S rake package
(in /Users/stephen/dev/ruby/src/gems/redcloth.git)
mkdir -p pkg
ragel ext/redcloth_scan/redcloth_scan.java.rl -J -T0 -o ext/redcloth_scan/RedclothScanService.java
rake aborted!
Command failed with status (1): [ragel ext/redcloth_scan/redcloth_scan.java...]
/Users/stephen/dev/ruby/src/gems/redcloth.git/Rakefile:133:in `ragel'
(See full trace by running task with --trace)
[redcloth.git (master)]$ jruby -S rake package --trace
(in /Users/stephen/dev/ruby/src/gems/redcloth.git)
** Invoke package (first_time)
** Invoke gem (first_time)
** Invoke pkg/RedCloth-4.1.10-universal-java.gem (first_time)
** Invoke pkg (first_time, not_needed)
** Invoke bin/redcloth (first_time, not_needed)
** Invoke CHANGELOG (first_time, not_needed)
** Invoke COPYING (first_time, not_needed)
** Invoke ext/redcloth_scan/extconf.rb (first_time, not_needed)
** Invoke ext/redcloth_scan/redcloth.h (first_time, not_needed)
** Invoke lib/case_sensitive_require/RedCloth.rb (first_time, not_needed)
** Invoke lib/redcloth/erb_extension.rb (first_time, not_needed)
** Invoke lib/redcloth/formatters/base.rb (first_time, not_needed)
** Invoke lib/redcloth/formatters/html.rb (first_time, not_needed)
** Invoke lib/redcloth/formatters/latex.rb (first_time, not_needed)
** Invoke lib/redcloth/formatters/latex_entities.yml (first_time, not_needed)
** Invoke lib/redcloth/textile_doc.rb (first_time, not_needed)
** Invoke lib/redcloth/version.rb (first_time, not_needed)
** Invoke lib/redcloth.rb (first_time, not_needed)
** Invoke lib/tasks/pureruby.rake (first_time, not_needed)
** Invoke Manifest (first_time, not_needed)
** Invoke Rakefile (first_time, not_needed)
** Invoke README (first_time, not_needed)
** Invoke setup.rb (first_time, not_needed)
** Invoke test/basic.yml (first_time, not_needed)
** Invoke test/code.yml (first_time, not_needed)
** Invoke test/definitions.yml (first_time, not_needed)
** Invoke test/extra_whitespace.yml (first_time, not_needed)
** Invoke test/filter_html.yml (first_time, not_needed)
** Invoke test/filter_pba.yml (first_time, not_needed)
** Invoke test/helper.rb (first_time, not_needed)
** Invoke test/html.yml (first_time, not_needed)
** Invoke test/images.yml (first_time, not_needed)
** Invoke test/instiki.yml (first_time, not_needed)
** Invoke test/links.yml (first_time, not_needed)
** Invoke test/lists.yml (first_time, not_needed)
** Invoke test/poignant.yml (first_time, not_needed)
** Invoke test/sanitize_html.yml (first_time, not_needed)
** Invoke test/table.yml (first_time, not_needed)
** Invoke test/test_custom_tags.rb (first_time, not_needed)
** Invoke test/test_erb.rb (first_time, not_needed)
** Invoke test/test_extensions.rb (first_time, not_needed)
** Invoke test/test_formatters.rb (first_time, not_needed)
** Invoke test/test_parser.rb (first_time, not_needed)
** Invoke test/test_restrictions.rb (first_time, not_needed)
** Invoke test/textism.yml (first_time, not_needed)
** Invoke test/threshold.yml (first_time, not_needed)
** Invoke test/validate_fixtures.rb (first_time, not_needed)
** Invoke RedCloth.gemspec (first_time)
** Invoke build_gemspec (first_time)
** Execute build_gemspec
** Execute RedCloth.gemspec
** Invoke lib/redcloth_scan.jar (first_time)
** Invoke ext/redcloth_scan/RedclothScanService.java (first_time)
** Invoke ext/redcloth_scan/redcloth_scan.java.rl (first_time, not_needed)
** Invoke ext/redcloth_scan/redcloth_scan.rl (first_time, not_needed)
** Invoke ext/redcloth_scan/redcloth_common.java.rl (first_time, not_needed)
** Invoke ext/redcloth_scan/redcloth_common.rl (first_time, not_needed)
** Execute ext/redcloth_scan/RedclothScanService.java
ragel ext/redcloth_scan/redcloth_scan.java.rl -J -T0 -o ext/redcloth_scan/RedclothScanService.java
rake aborted!
Command failed with status (1): [ragel ext/redcloth_scan/redcloth_scan.java...]
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:969:in `sh'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:982:in `call'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:982:in `sh'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1074:in `sh'
/Users/stephen/dev/ruby/src/gems/redcloth.git/Rakefile:133:in `ragel'
/Users/stephen/dev/ruby/src/gems/redcloth.git/Rakefile:247:in `ensure_ragel_version'
/Users/stephen/dev/ruby/src/gems/redcloth.git/Rakefile:132:in `ragel'
/Users/stephen/dev/ruby/src/gems/redcloth.git/Rakefile:153
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:617:in `call'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:617:in `execute'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:612:in `each'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:612:in `execute'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:578:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `each'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `each'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `each'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:588:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `each'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:585:in `invoke_prerequisites'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:577:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:571:in `invoke_with_call_chain'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:564:in `invoke'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2027:in `invoke_task'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2005:in `top_level'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2005:in `each'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2005:in `top_level'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2044:in `standard_exception_handling'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1999:in `top_level'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1977:in `run'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:2044:in `standard_exception_handling'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/lib/rake.rb:1974:in `run'
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/bin/rake:31
/Users/stephen/dev/ruby/src/jruby.git/lib/ruby/gems/1.8/gems/rake-0.8.4/bin/rake:19:in `load'
/Users/stephen/dev/ruby/src/jruby.git/bin/rake:19
[redcloth.git (master)]$ port installed ragel
The following ports are currently installed:
  ragel @6.0_0
  ragel @6.2_0
  ragel @6.3_0 (active)

Comments and changes to this ticket

  • Jason Garber

    Jason Garber June 10th, 2009 @ 10:19 AM

    • State changed from “new” to “resolved”

    I think I fixed it. Please verify for me.

  • Stephen Bannasch

    Stephen Bannasch June 10th, 2009 @ 11:24 AM

    Yes, this now works.
    Thanks a bunch Jason!

    [redcloth.git (master)]$ jruby --version
    jruby 1.3.0RC2 (ruby 1.8.6p287) (2009-06-03 6586) (Java HotSpot(TM) Client VM 1.5.0_16) [i386-java]
    [redcloth.git (master)]$ 
    
    [redcloth.git (master)]$ jruby -S rake package
    (in /Users/stephen/dev/ruby/src/gems/redcloth.git)
    ragel ext/redcloth_scan/redcloth_scan.java.rl -J -o ext/redcloth_scan/RedclothScanService.java
    ragel ext/redcloth_scan/redcloth_inline.java.rl -J -o ext/redcloth_scan/RedclothInline.java
    ragel ext/redcloth_scan/redcloth_attributes.java.rl -J -o ext/redcloth_scan/RedclothAttributes.java
    javac -target 1.5 -source 1.5 -d ext/redcloth_scan -cp /Users/stephen/dev/ruby/src/jruby.git/lib/jruby-complete.jar:/Users/stephen/dev/ruby/src/jruby.git/lib/jruby.jar:/Users/stephen/dev/ruby/src/jruby.git/lib/profile.jar:.:/Users/stephen/dev/junit4.1: ext/redcloth_scan/RedclothAttributes.java ext/redcloth_scan/RedclothInline.java ext/redcloth_scan/RedclothScanService.java
    jar cf lib/redcloth_scan.jar -C ext/redcloth_scan .
      Successfully built RubyGem
      Name: RedCloth
      Version: 4.1.10
      File: RedCloth-4.1.10-universal-java.gem
    mv RedCloth-4.1.10-universal-java.gem pkg/RedCloth-4.1.10-universal-java.gem
    Private key not found; gem will not be signed.
    Targeting "universal-java" platform.
    

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

RedCloth is a Ruby library for converting Textile into HTML

Shared Ticket Bins

People watching this ticket

Tags

Pages